domingo, 25 de octubre de 2009

El click no anda en flash para ubuntu 9.10 (Karmic Koala)

Si se dan estas condiciones:
  • Usando Karmic Koala
  • El click en flash no anda (no se pueden pausar videos de youtube por ejemplo)
  • Usando arquitectura de 64 bits (amd64)
La solución es simple, hay que bajar de acá el tar.gz de flash para 64 bits, y descomprimirlo en /usr/lib/mozilla/plugins/

**Update comprobado**
En una máquina en particular despues de hacer todo esto e incluso lo que dice en los mensajes, seguía funcionándome mal. Después de todas estas pruebas, hice este remedio casero que funcionó definitivamente.

Primero descomprimi el libflashplayer.so al escritorio, y lo copié a los 3 lados que debería estar:
$ sudo cp ~/Desktop/libflashplayer.so /usr/lib/mozilla/plugins/
$ sudo cp ~/Desktop/libflashplayer.so ~/.mozilla/plugins/
$ sudo cp ~/Desktop/libflashplayer.so /usr/lib/mozilla/plugins/

Luego me aseguré de borrar todas las copias que hubiera del .so que no fueran esas 3 que yo estaba usando. Para eso hice:
locate libflashplayer.so
(Nota al margen: el locate es un comando particularmente poderoso e util, en algun momento voy a escribir al respecto)

En definitiva y lo aclaro al margen, tuve que borrar 2 copias en particular que ni siquiera tienen el mismo nombre, que son las siguientes:
$ sudo rm -f /usr/share/ubufox/plugins/npwrapper.libflashplayer.so
$ sudo rm -f /var/lib/flashplugin-installer/npwrapper.libflashplayer.so
Igual YMMV, asi que asumo que lo mas recomendable es borrar todos. Por otro lado, yo los borre porque no soy precavido, lo mas recomendable sería moverlos a un lugar seguro por si algo crítico se rompe, si alguien prueba este método y tiene problemas no digan que no les avisé. También, en la parte de la solución, probablemente sea mejor hacer links dinámicos al .so y no copiarlo 3 veces. Estoy al tanto de eso, pero bueno, salió así y así funciona.

Si a alguien le funciona/no le funciona, sírvanse avisar en los comments. Parece ser que es un tema que está molestando a mucha gente (a mí en particular me pasó en las 3 máquinas de 64 bits que instalé)

11 comentarios:

Mauricio Andres dijo...

lamento decir que no funciona,cero que la actualización 9.04 a 9.10 es errónea, ya que ningun método funciona.

Kewl dijo...

Otro detalle que podés probar si no te funcionó, es revisar que no haya un libflashplayer.so en ~/.mozilla/plugins/

en ese caso reemplazalo también.

Cmop dijo...

tengo el mismo problema, probare tu solucion

Cmop dijo...

Hola amigo, gracias por la dirección del plugin probé tu método y debo agregar que tb se deberia instalar la libreria libadns1, osea
sudo apt-get install libadns1

Y con eso ya funciona muy bien, saludos.

Angelverde dijo...

Vaya! Eso mismo me sucedio.

Angelverde dijo...

Diste un link malo, me dirige al plugin de 32 bits, este es el bueno: http://labs.adobe.com/technologies/flashplayer10/64bit.html

Angelverde dijo...

@Kewl encontre la solución definitiva y milagrosa aqui: http://astoryworthtelling.wordpress.com/2009/11/09/cant-click-in-flash-using-ubuntu-9-10-karmic-try-this/

Es lo unico que me funciono.

inyaka dijo...

@Angelverde la solución planteada en esa pagina tambien me funciona y a la primera, sin haber echo ninguna payasada antes a tontas y a locas :P

recomiendo también dicho link http://astoryworthtelling.wordpress.com/2009/11/09/cant-click-in-flash-using-ubuntu-9-10-karmic-try-this/

Albertillo dijo...

Yo también llevo mucho tiempo dandole vueltas al problema sin llegar a solucionarlo del todo.

Lo único que me funciona cuando esto pasa (que no es siempre) es pulsar la tecla CTRL al mismo tiempo que hago "click" sobre el control del flashplayer.

Uso Kubuntu 9.10 y hasta hoy pensaba que era un problema de composición de KDE, pero por lo visto también pasa en Gnome ...

Kewl dijo...

Albertillo, probaste eso la solución que dice el update ? a mi en la maquina que no me funcionaba es porque me quedaba la libreria vieja con otro nombre por ahi y me la tomaba igual. El truco es asegurarse que no te quede ninguna copia que no sea la de 64 bits.

Albertillo dijo...

Hola de nuevo @Kewl
he reemplazado estos tres (con "cp" a lo salvaje) por la librería oficial de Adobe:
/usr/lib/flashplugin-installer/libflashplayer.so
/usr/lib/flashplugin-nonfree/libflashplayer.so
/usr/share/ubufox/plugins/libflashplayer.so


De momento los players se portan bien; pero ya digo, los problemas de interacción solo aparecen a veces.

Por cierto, yo uso la versión de 32bits y la libreria de Adobe, por supuesto, es la que toca (32bits).